Works by

Ren's blog

アプリケーションバックエンド中心に書いていきます

【npm/yarn】パッケージをダウングレードする

f:id:rennnosukesann:20181223181823p:plain:w500

メモ。

npm では、パッケージのダウングレードを行う場合、一旦パッケージを削除してから再度インストールし直す必要があります。

$ npm remove cowsay
$ npm install --save cowsay@1.0.0

yarn であれば、 yarn upgrade [パッケージ名]@[version] で指定したバージョンにそのままダウングレードしてくれます。もちろんアップグレードも可能。

$ yarn upgrade cowsay@1.0.0

yarn は楽でいいですね。個人的には npm と違ってデフォルトでローカルパッケージインストールなのが安心です。